Maverick Legacy Server 1.7.34

JADAPTIVE Limited is pleased to announce the release of Maverick Legacy Server 1.7.34. Builds are now available for download from your account. Thank you to all customers that have helped by reporting issues and confirming fixes.

This release is primarily a bug fix release; however, please pay particular attention to the change in dependency support for Ed25519.

OpenSSH Certificate Support

Over the past couple of releases, we have been refining support for OpenSSH Certificates. It is now possible to generate both User and Host Certificates using the API. 

We have several resources to help you get started. 

OpenSSH Certificate Cheat Sheet
https://www.jadaptive.com/openssh-certificate-cheat-sheet/

Generating and Using OpenSSH User Certificates
https://www.jadaptive.com/app/manpage/en/article/2895616

Generating and Using OpenSSH Host Certificates
https://www.jadaptive.com/app/manpage/en/article/2895831

ED25519 Dependencies

With 1.7.34, we have changed the dependency required to support Ed25519 keys. We now use the BouncyCastle JCE to implement this key algorithm instead of the EdDSA-Java project.

While the current implementation requires the BouncyCastle JCE, we hope that this will enable us to support Ed25519 from any JCE that supports the algorithm in the long term.

Users should now use a version of the BouncyCastle JCE that supports Ed25519 and remove eddsa-0.3.0.jar from their dependencies. We tested the implementation with BouncyCastle 1.64.

Changelog

The full changelog is available from https://www.jadaptive.com/app/api/versions/changes/Maverick%20Legacy%20Server/